$re = '/(-\w+)(?:=|\s)?("[^"]*"|\S+)?/';
$str = '-arg1 -arg2 -arg3=500 -arg4=-250,200,50.0 -arg5 "Hello World" -arg6 "[I don\'t know whats going on /here/]" -arg7="this works too"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);