import Foundation
let pattern = #"^raw_data\.(?!((event_record_string|event_record_binary|event_record_binary\.event_record_binary)\.prod\.(18477|18478|5416|5454|5455)|storage\.aw|codo)\.)(?!.*(failure_permanent|failure_\d+_\w+)$).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"raw_data.foo.bar"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}