$re = '/(^#+ )[^\[]*?\[\[Wikilink]\][^\n]*?\n([\S\s]*?)(?1)/m';
$str = '# Part 1
## Some title 1 [[Wikilink]]
Some
random
content
### Sub title 1
Content
### Sub item 2
Content
## Other title 2
Content
# Part 2
## title
### Sub item [[Wikilink]]
content here
## title
# Part 3 [[Wikilink]]
content';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);