$re = '/^.*getInitialProps[\s\S]*?\bdispatch[\s\S]*?(return).*\n.*/m';
$str = 'import React from \'react\'
class Page extends React.Component {
static async getInitialProps(ctx) {
const res = await fetch(\'https://api.github.com/repos/zeit/next.js\')
const json = await res.json()
dispatchEvent(event)
return { stars: json.stargazers_count }
}
render() {
return <div>Next stars: {this.props.stars}</div>
}
}
export default Page
class Page extends React.Component {
static async getInitialProps(ctx) {
const res = await fetch(\'https://api.github.com/repos/zeit/next.js\')
const json = await res.json()
return { stars: json.stargazers_count }
}
render() {
return <div>Next stars: {this.props.stars}</div>
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);