package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-(NS|PD|SP)-(\w+)`)
var str = `http://vayes-eys.dev/shoe-for-ladies/high-hields/7-pont-with-silver-stripes-PD-0a8564q56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}