re = /-(NS|PD|SP)-(\w+)/
str = 'http://vayes-eys.dev/shoe-for-ladies/high-hields/7-pont-with-silver-stripes-PD-0a8564q56'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end