import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1(1[2578]|2([09]80|3(45|)|5(3?0|5)|7[67])|414|6(200|(80|91)\\d|99[015679])|8(28|91))|(2([1-8]\\d|9[136])|30\\d|7(0[789]|60)|80[08]|9([136]\\d|[124-7]))(\\d{6})$";
final String string = "112\n"
+ "16912\n"
+ "1414\n"
+ "16805\n"
+ "16200\n"
+ "16804\n"
+ "211234567\n"
+ "707123456\n"
+ "760123456\n"
+ "911250000\n"
+ "911212000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}