import re
regex = re.compile(r"^1(1[2578]|2([09]80|3(45|)|5(3?0|5)|7[67])|414|6(200|(80|91)\d|99[015679])|8(28|91))|(2([1-8]\d|9[136])|30\d|7(0[789]|60)|80[08]|9([136]\d|[124-7]))(\d{6})$", flags=re.MULTILINE)
test_str = ("112\n"
"16912\n"
"1414\n"
"16805\n"
"16200\n"
"16804\n"
"211234567\n"
"707123456\n"
"760123456\n"
"911250000\n"
"911212000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")