$re = '/^
(?=.{12,}) # at least 12 characters
(?=(?:[^a-z]*[a-z]){3,}) # at least 3 lowercase characters
(?=(?:[^A-Z]*[A-Z]){3,}) # at least 3 uppercase characters
(?=(?:[^0-9]*[0-9]){1,}) # a number
(?=(?:[^ -\/:-@[-`{-~]*[ -\/:-@[-`{-~]){1,}) # a special character
.*$/x';
$str = 'azertYUIOP8*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);