// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^
(?=.{12,}) # at least 12 characters
(?=(?:[^a-z]*[a-z]){3,}) # at least 3 lowercase characters
(?=(?:[^A-Z]*[A-Z]){3,}) # at least 3 uppercase characters
(?=(?:[^0-9]*[0-9]){1,}) # a number
(?=(?:[^ -\/:-@[-`{-~]*[ -\/:-@[-`{-~]){1,}) # a special character
.*$").unwrap();
let string = "azertYUIOP8*
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}