#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "googletag\.defineSlot.*?'([^']*)'\);"
Local $sString = "googletag.defineSlot('Lorem1', [300, 100], 'div-ad-1430201576110-0');" & @CRLF & _
"googletag.defineSlot('Lorem2', [300, 100], 'div-ad-1442774220958-0');" & @CRLF & _
"googletag.defineSlot('Lorem3', [300, 100], 'div-ad-1448024965037-0');" & @CRLF & _
"googletag.defineSlot('Lorem4', [290, 60], 'div-ad-1429688274462-0');" & @CRLF & _
"googletag.defineSlot('Lorem5', [300, 200], 'div-ad-1448279284710-0');" & @CRLF & _
"googletag.defineSlot('Lorem6', [728, 90], 'div-ad-1389610933954-2');" & @CRLF & _
"googletag.defineSlot('Lorem7', [728, 90], 'div-ad-1389610933954-4');" & @CRLF & _
"googletag.defineSlot('Lorem8', [300, 250], 'div-ad-1389610933954-0');" & @CRLF & _
"googletag.defineSlot('Lorem9', [300, 250], 'div-ad-1448278717664-0');" & @CRLF & _
"googletag.defineSlot('Lorem10',[300, 250] 'div-ad-1425381569546-1');" & @CRLF & _
"googletag.defineOutOfPageSlot('Lorem11','div-ad-1424524422308-0-oop1');" & @CRLF & _
"googletag.defineOutOfPageSlot('Lorem12','div-ad-1424524422308-0-oop2');" & @CRLF & _
"googletag.defineOutOfPageSlot('Lorem13','div-ad-1389610933954-0-oop4');" & @CRLF & _
"googletag.defineOutOfPageSlot('Lorem14','div-ad-1389610933954-0-oop5');" & @CRLF & _
"googletag.defineOutOfPageSlot('Lorem15','div-ad-1389610933954-0-oop6');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")