import re
regex = re.compile(r"googletag\.defineSlot.*?'([^']*)'\);")
test_str = ("googletag.defineSlot('Lorem1', [300, 100], 'div-ad-1430201576110-0');\n"
"googletag.defineSlot('Lorem2', [300, 100], 'div-ad-1442774220958-0');\n"
"googletag.defineSlot('Lorem3', [300, 100], 'div-ad-1448024965037-0');\n"
"googletag.defineSlot('Lorem4', [290, 60], 'div-ad-1429688274462-0');\n"
"googletag.defineSlot('Lorem5', [300, 200], 'div-ad-1448279284710-0');\n"
"googletag.defineSlot('Lorem6', [728, 90], 'div-ad-1389610933954-2');\n"
"googletag.defineSlot('Lorem7', [728, 90], 'div-ad-1389610933954-4');\n"
"googletag.defineSlot('Lorem8', [300, 250], 'div-ad-1389610933954-0');\n"
"googletag.defineSlot('Lorem9', [300, 250], 'div-ad-1448278717664-0');\n"
"googletag.defineSlot('Lorem10',[300, 250] 'div-ad-1425381569546-1');\n"
"googletag.defineOutOfPageSlot('Lorem11','div-ad-1424524422308-0-oop1');\n"
"googletag.defineOutOfPageSlot('Lorem12','div-ad-1424524422308-0-oop2');\n"
"googletag.defineOutOfPageSlot('Lorem13','div-ad-1389610933954-0-oop4');\n"
"googletag.defineOutOfPageSlot('Lorem14','div-ad-1389610933954-0-oop5');\n"
"googletag.defineOutOfPageSlot('Lorem15','div-ad-1389610933954-0-oop6');")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")