package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\d+]|\b\D+`)
var str = `+41 456-7891+23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}