$re = '/^[^\d+]|\b\D+/';
$str = '+41 456-7891+23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);