const regex = /Å\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Å\\s', 'g')
const str = `Å apat`;
const subst = `Š`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);