#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)F Blocks:[\t ]+(0x)?([0-9a-f]+)[ ]+(0x)?([0-9a-f]+)[ ]+(0x)?([0-9a-f]+)"
Local $sString = "Entry : 12300000" & @CRLF & _
"F Blocks: 00000020 0x00000000 0x000a1b00" & @CRLF & _
"S Blocks: 0x00100000 0x0000001c 0x00000150"
Local $sSubst = "0x\2 0x\4 0x\6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)