import Foundation
let pattern = #"F Blocks:[\t ]+(0x)?([0-9a-f]+)[ ]+(0x)?([0-9a-f]+)[ ]+(0x)?([0-9a-f]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Entry : 12300000
F Blocks: 00000020 0x00000000 0x000a1b00
S Blocks: 0x00100000 0x0000001c 0x00000150
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0x\2 0x\4 0x\6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)