package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){3}([01]?\d?\d|2[0-4]\d|25[0-5])$`)
var str = `255.145.246.34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}