re = /^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){3}([01]?\d?\d|2[0-4]\d|25[0-5])$/mi
str = '255.145.246.34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end