import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http:\\/\\/|https:\\/\\/|ftp:\\/\\/|www.|pop:\\/\\/|imap:\\/\\/){1}([0-9A-Za-z]+\\.)";
final String string = "http://devices/\n"
+ "ftp://dddddddd/\n\n\n"
+ "http://devices.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}