re = /^(http:\/\/|https:\/\/|ftp:\/\/|www.|pop:\/\/|imap:\/\/){1}([0-9A-Za-z]+\.)/m
str = 'http://devices/
ftp://dddddddd/
http://devices.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end