$re = '/(.*)(\d+)(.*)/m';
$str = 'This order was placed for QT3000! OK?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);