using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?!you).*\?$";
string input = @"cowyouare
elephantiam
mosquitoyouseemtobe
mokeyyoumight
tmyou
UVM_INFO @ 2825.0ns: [ig_scb] PARITY_ERROR detected
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}