import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?msi)\\[GC\\s+[\\d\\.]+:\\s+\\[ParNew:[^\\]]+\\]\\s+(?<JVM_HeapUsedBeforeGC>[\\d\\.KM]+)->(?<JVM_HeapUsedAfterGC>[\\d\\.KM]+)\\((?<JVM_HeapSize>[\\d\\.KM]+)\\),\\s+(?<JVM_GCTimeTaken>[\\d\\.]+ secs)\\]\\s+\\[Times: user=(?<user>[\\d\\.]+)";
final String string = "[GC 44625.964: [ParNew: 929756K->161792K(1071552K), 0.0821116 secs] 10302433K->9534469K(13121984K), 0.0823159 secs] [Times: user=0.63 sys=0.00, real=0.08 secs]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}