const regex = /(?msi)\[GC\s+[\d\.]+:\s+\[ParNew:[^\]]+\]\s+(?<JVM_HeapUsedBeforeGC>[\d\.KM]+)->(?<JVM_HeapUsedAfterGC>[\d\.KM]+)\((?<JVM_HeapSize>[\d\.KM]+)\),\s+(?<JVM_GCTimeTaken>[\d\.]+ secs)\]\s+\[Times: user=(?<user>[\d\.]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?msi)\\[GC\\s+[\\d\\.]+:\\s+\\[ParNew:[^\\]]+\\]\\s+(?<JVM_HeapUsedBeforeGC>[\\d\\.KM]+)->(?<JVM_HeapUsedAfterGC>[\\d\\.KM]+)\\((?<JVM_HeapSize>[\\d\\.KM]+)\\),\\s+(?<JVM_GCTimeTaken>[\\d\\.]+ secs)\\]\\s+\\[Times: user=(?<user>[\\d\\.]+)', '')
const str = `[GC 44625.964: [ParNew: 929756K->161792K(1071552K), 0.0821116 secs] 10302433K->9534469K(13121984K), 0.0823159 secs] [Times: user=0.63 sys=0.00, real=0.08 secs]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}