$re = '/(?<=^\?(?:&?[a-z=]+(?![a-z=]))*&?)[a-z=]+/';
$str = '?some=querystring&ssembly=containing&n=indeterminate&mount=of&ll=potentially&ccordant=matches';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);