re = /(?<=^\?(?:&?[a-z=]+(?![a-z=]))*&?)[a-z=]+/
str = '?some=querystring&ssembly=containing&n=indeterminate&mount=of&ll=potentially&ccordant=matches'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end