#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^\s*D\d+\.node\s+\(([\d.]+)\):(?:(?!^\s*(?:D\d+\.node|Success rate is )\s).)*^\s*Success rate is 0\b"
Local $sString = " Job Engine: Job engine1" & @CRLF & _
" " & @CRLF & _
" 05/05/2016 15:13:31 : Started PING ISDN : JobDescription_1defa6e9-1c83-4909-bc13-36d2e1205096" & @CRLF & _
" " & @CRLF & _
" Execute Command Script on Devices" & @CRLF & _
" Where (NCM_Group = 'ATM WAN Routers')" & @CRLF & _
" " & @CRLF & _
" D002.node (10.188.188.188):" & @CRLF & _
" " & @CRLF & _
" --------------" & @CRLF & _
" ping 10.191.231.254" & @CRLF & _
" --------------" & @CRLF & _
" Type escape sequence to abort." & @CRLF & _
" Sending 5, 100-byte ICMP Echos to 10.91.31.254, timeout is 2 seconds:" & @CRLF & _
" ....." & @CRLF & _
" Success rate is 80 percent (4/5)" & @CRLF & _
" " & @CRLF & _
" ___________________________________________________________________________" & @CRLF & _
" D069.node (10.0.0.182):" & @CRLF & _
" " & @CRLF & _
" --------------" & @CRLF & _
" ping 10.191.231.254" & @CRLF & _
" --------------" & @CRLF & _
" Type escape sequence to abort." & @CRLF & _
" Sending 5, 100-byte ICMP Echos to 10.91.31.254, timeout is 2 seconds:" & @CRLF & _
" ..!!!" & @CRLF & _
" Success rate is 60 percent (3/5), round-trip min/avg/max = 32/32/32 ms" & @CRLF & _
" " & @CRLF & _
" ___________________________________________________________________________" & @CRLF & _
" D069.node (10.0.0.183):" & @CRLF & _
" " & @CRLF & _
" --------------" & @CRLF & _
" ping 10.191.231.254" & @CRLF & _
" --------------" & @CRLF & _
" Type escape sequence to abort." & @CRLF & _
" Sending 5, 100-byte ICMP Echos to 10.91.31.254, timeout is 2 seconds:" & @CRLF & _
" ..!!!" & @CRLF & _
" Success rate is 0 percent (0/5), round-trip min/avg/max = 32/32/32 ms" & @CRLF & _
" " & @CRLF & _
" ___________________________________________________________________________"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")