$re = '/^\s*D\d+\.node\s+\(([\d.]+)\):(?:(?!^\s*(?:D\d+\.node|Success rate is )\s).)*^\s*Success rate is 0\b/ms';
$str = ' Job Engine: Job engine1
05/05/2016 15:13:31 : Started PING ISDN : JobDescription_1defa6e9-1c83-4909-bc13-36d2e1205096
Execute Command Script on Devices
Where (NCM_Group = \'ATM WAN Routers\')
D002.node (10.188.188.188):
--------------
ping 10.191.231.254
--------------
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.91.31.254, timeout is 2 seconds:
.....
Success rate is 80 percent (4/5)
___________________________________________________________________________
D069.node (10.0.0.182):
--------------
ping 10.191.231.254
--------------
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.91.31.254, timeout is 2 seconds:
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 32/32/32 ms
___________________________________________________________________________
D069.node (10.0.0.183):
--------------
ping 10.191.231.254
--------------
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.91.31.254, timeout is 2 seconds:
..!!!
Success rate is 0 percent (0/5), round-trip min/avg/max = 32/32/32 ms
___________________________________________________________________________';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);