import re
regex = re.compile(r"^(?:([[:alnum:]_-]{1,63})\.)*(?:[[:alnum:]-]{2,63})(?:\.[[:alpha:]]{2,63})+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1\n"
"11.com\n"
"1.2.3.4\n"
"1.1.2\n"
"1ab.com\n"
"www.domain.com\n"
"domain.com\n"
"53dw4vbsf3yf53nnc7yq7fijlp7ymnbx.dkim.amazonses.com\n"
"53dw4vbsf3yf53nnc7yq7fijlp7ymnbx._domainkey.domain.com\n"
"a.b.c.d.e.f.ggg.com.au\n"
"a1b2c3.com\n"
"a111.com\n"
"http://nope.com\n"
"example\n"
"webmagnat.ro\n"
"nickelfreesolutions.com\n"
"scheepvaarttelefoongids.nl\n"
"tursan.net\n"
"plannersanonymous.com\n"
"doing.fr\n"
"saltstack.com\n"
"deconsquad.com\n"
"migom.com\n"
"tjprc.org\n"
"worklife.dk\n"
"inno-make.com\n"
"food-hub.org\n"
"bikemastertool.com\n"
"betenbewegen.de\n"
"vk.me\n"
"twotigersports.com\n"
"517mrt.com\n"
"siel.nl\n"
"e-hps.com\n"
"infowheel.com\n"
"synirc.net\n"
"abuliyan.com\n"
"easy-ways.com\n"
"stark.dk\n"
"funwirks.com\n"
"eurocqs.net\n"
"202yx.com\n"
"nikko-sake.com\n"
"xnet.lv\n"
"visionpharma.com\n"
"trade-india.com\n"
"t-bird.edu\n"
"siebel-crm.net\n"
"adriaticapress.it\n"
"41789.com\n"
"autofirenze.biz\n"
"minniowa.com\n"
"sweetteaproper.com\n"
"recruit-dc.co.jp\n"
"competitivecameras.com\n"
"zoncinta.com\n"
"vadim-prostakov.ru\n"
"vk.me\n"
"securitasweb.it\n"
"mandarinclass.my\n"
"pbxi.net\n"
"zyznowski.pl\n"
"meodia.com\n"
"niceinternetmoney.ru\n"
"guardiancaps.com\n"
"bbccable.net\n"
"ams-luenen.de\n"
"ihalehaberbulteni.com\n"
"salvia-community.net\n"
"superpowerfruits.com\n"
"bereyellingergl.com\n"
"downloadfreetvseries.com\n"
"iqshop.ro\n"
"urbancliq.com\n"
"rocket-media.net\n"
"uskudarhaliyikama.org\n"
"ftbp.ro\n"
"savedeo.com\n"
"nanabit.net\n"
"memewood.com\n"
"divorcereform.us\n"
"solarincomefund.com\n"
"novofri.com\n"
"8852088.com\n"
"admil.ru\n"
"rafonline.org\n"
"bois-francs.com\n"
"pieceinch.com\n"
"tel.com\n"
"teenpregnancysc.org\n"
"wisdomforhealth.net\n"
"powgnar.com\n"
"screenmediamag.com\n"
"pricerabbit.com\n"
"archive-host.fr\n"
"hotimpit.ru\n"
"detskie-krovatki.by\n"
"3sitracking.com\n"
"hellfiremods.co.uk\n"
"eslyoga.com\n"
"buyphen375cheap.com\n"
"kilgour.com\n"
"vk.me\n"
"hualienhouse.com\n"
"tour-box.ru\n"
"servizioallerta.it\n"
"denyojp.com\n"
"2912muranoway.info\n"
"centralepiecesauto.com\n"
"bluedynamics.com\n"
"xjs123.com\n"
"veryicon.com\n"
"emrekoldas.com\n"
"adc-inspect.com\n"
"vusadbe.by\n"
"morban.co.uk\n"
"hainanair.us\n"
"vk.me\n"
"metar.gr\n"
"reviewsearchfree.com\n"
"treasureislandbar.com\n"
"mobilier-bebe.com\n"
"bvillaseminyak.com\n"
"sponsoredhomepage.com\n"
"santifortwo.com\n"
"pcrecruiter.net\n"
"bcdtofu.com\n"
"thefavorite.fr\n"
"aneventapart.com\n"
"pces.in\n"
"alamelphan.com\n"
"hotel63.com\n"
"kitubi.com\n"
"zenrog.com\n"
"kinderroller.org\n"
"naverisk.com\n"
"teme.us\n"
"tlinkbroadband.com\n"
"de.vc\n"
"rivnetwork.com\n"
"bufobufo.eu\n"
"friatider.se\n"
"mannllc.com\n"
"rideukbmx.com\n"
"agnx.com\n"
"stackablehost.com\n"
"muzed.co.uk\n"
"up247.me\n"
"vk.com\n"
"urt.is\n"
"notabilus.com\n"
"jordansun.com\n"
"frosta.hu\n"
"lacuisinedegandi.net\n"
"baolongphoto.com\n"
"sheispriceless.com\n"
"retail.ua\n"
"pattaya-bargirl-investigations.com\n"
"teksyndicate.com\n"
"d-strage.jp\n"
"akselparis.com\n"
"lilylolo.co.uk\n"
"mockquestions.com\n"
"rocketdownload.com\n"
"shopkeepapp.com\n"
"postageapp.com\n"
"mkhoj.com\n"
"ingwer-gesundheit.de\n"
"velvetblues.com\n"
"deltacountytx.com\n"
"idenyt.dk\n"
"searchforrecipes.info\n"
"simf-net.ru\n"
"fraserwebdesign.co.uk\n"
"runboard.com\n"
"worldoutofbalance.org\n"
"amrefgermany.de\n"
"ricochettrendz.com\n"
"logicspot.net\n"
"johnbarritt.com\n"
"westfest.co.nz\n"
"x-muehle.de\n"
"vk.me\n"
"ford-2sale.com\n"
"kinoman.tv\n"
"akorda.kz\n"
"terrania.ru\n"
"selmanpeskir.com\n"
"waydesgin.com\n"
"jcdrepair.com\n"
"omegamepis.com\n"
"answersforapple.com\n"
"videofeet.com\n"
"luxeweddingdesign.com\n"
"thepropertyvault.co.uk\n"
"managedemail.com\n"
"hrhairextensions.com\n"
"triecienspeks.lv\n"
"photoshooting-art.com\n"
"dns-roots.net\n"
"statice.is\n"
"sygeforsikring.dk\n"
"pleg.ma\n"
"memecorner.com\n"
"wimmercycle.com\n"
"sugoikr.com\n"
"hennensobserver.com\n"
"phim8.vn\n"
"kaoxve.com\n"
"mastitorrents.com\n"
"choople.com\n"
"all-nude-celebs.us\n"
"techpowertw.com\n"
"gwynnemeeks.com\n"
"eissmann.com\n"
"foxydeal.in\n"
"bigglook.com\n"
"camdough.com\n"
"blazingcore.com\n"
"vn-logistics.nl\n"
"hacogata.com\n"
"inspiradigital.co.uk\n"
"ce-richtlinien.eu\n"
"djbarryblends.com\n"
"untitledradio.com\n"
"chinahomegift.com\n"
"zgdaliw.com\n"
"qfpay.com\n"
"84tao.com\n"
"farat.ru\n"
"sootooo.com\n"
"vk.me\n"
"trianglemoon.com\n"
"golf-absolute.de\n"
"grtplains.com\n"
"windmillchiropractic.com\n"
"thegrillbbqstore.com\n"
"veronline.li\n"
"giga-cv.com\n"
"xaman.com\n"
"maurerundpartner.com\n"
"opf-labs.org\n"
"plinks.jp\n"
"lithiaelectrolysis.com\n"
"kentuckysportsradio.com\n"
"welding.su\n"
"design-pilot.com\n"
"wcsr.com\n"
"telemagazyn.pl\n"
"coldclimategardening.com\n"
"dallenhomeschoolreviews.com\n"
"guidgen.com\n"
"cafe-campus.ru\n"
"helander.co.uk\n"
"odwyk.com\n"
"toppsfootball.co.uk\n"
"morgane-le-fay.de\n"
"khamphamientrung.com\n"
"tas-t.com\n"
"comeser.it\n"
"spvgg-haddamshausen.de\n"
"winkhaus.com\n"
"netbridge.ro\n"
"frenzyestate.com\n"
"comprabolsos.com\n"
"medicclub.ru\n"
"akfarsam.ac.id\n"
"vk.me\n"
"rw-kupplungen.de\n"
"archers-contois.fr\n"
"dyndns.tv\n"
"visits.lt\n"
"us.tf\n"
"wholesalejerseyssaleus.com\n"
"supertabak.ru\n"
"vk.me\n"
"maketechpr.com\n"
"registratuperro.com\n"
"z9project.com\n"
"menkousou.com\n"
"futchfactor.com\n"
"sauipe.vc\n"
"peregrineadventures.com\n"
"daegusoft.com\n"
"rvillageman.com\n"
"ocs1.org\n"
"valleyfireworks.net\n"
"vk.me\n"
"jw.org\n"
"mcafeefamilyprotection.com\n"
"leblogexpectra.fr\n"
"schreibwirkstatt.de\n"
"doommovie.com\n"
"1600x1200.net\n"
"xn--verstt-eua3l.info\n"
"wallofsoundstudios.com\n"
"leernetwerkeducatie.nl\n"
"frommyheartproductions.net\n"
"pokupaisumom.ee\n"
"stiahnut.sk\n"
"fusionedgephotography.com\n"
"forum-wf.de\n"
"webmusic.asia\n"
"cic-tripleadvantage-creditreports.net\n"
"deeperfaith.org\n"
"geneeskundeboek.nl\n"
"andrewraposo.com\n"
"poolrepairaustin.com\n"
"ayto-oviedo.es\n"
"arianapassion.com\n"
"mpa-ppm.org\n"
"regus.it\n"
"myboardcast.com\n"
"amanto.be\n"
"srsportal.com\n"
"staffingcalendar.com\n"
"haikoheinz.de\n"
"bestelectriclawnmower.co.uk\n"
"ruitx.cn\n"
"jbbr.net\n"
"afresnohomeinspector.com\n"
"bathroomgurureview.mobi\n"
"barcanovainfantilijuvenil.cat\n"
"matandme.com\n"
"myra.com\n"
"search225.com\n"
"egyptopia.com\n"
"englishwordsexplained.com\n"
"spinetrac.com\n"
"tchl.us\n"
"az.gov\n"
"gaybodyblog.com\n"
"mailkenti.net\n"
"alldisneycartoons.com\n"
"globaldir.org\n"
"van-photo.com\n"
"alcostop.org\n"
"kurkiewicz-family.com\n"
"bookmarkingpages.com\n"
"newyork.com\n"
"karrdoctor.biz\n"
"herrajesarena.com\n"
"afisha64.ru\n"
"patsem2013.org\n"
"bikersworld-rathenow.de\n"
"openstreetmap.fr\n"
"jriver.com\n"
"umka.com\n"
"shipbroker.no\n"
"tradefair.com\n"
"tenkarausa.com\n"
"wincrm.net\n"
"usenettools.net\n"
"crsgfk.de\n"
"ellowcn.com\n"
"imperialantiques.com\n"
"moph.go.th\n"
"sharedpregnancy.org\n"
"youtubeinmp3.com\n"
"haoyisheng.com\n"
"silkroadtours.com\n"
"glsbc.com\n"
"downsyndromeiscool.com\n"
"tomsgames.it\n"
"mysearch-online.com\n"
"studiototal.se\n"
"glas-forschung.info\n"
"intuitionstraining.org\n"
"stedelijkgymnasiumhaarlem.nl\n"
"thecroydoncitizen.com\n"
"oddstowinworldseries.com\n"
"vivesoy.com\n"
"gt.com\n"
"ehgou.com\n"
"labelproducts.com\n"
"moln.is\n"
"mcdonaldsleon.com\n"
"ashishlunawat.com\n"
"vnsofts.com\n"
"idospower.cz\n"
"mmblog.tw\n"
"glob-marks.com\n"
"sceper.ws\n"
"thurlownunn.co.uk\n"
"moriyama.com\n"
"thompsonnutritionals.com\n"
"wandern-trekking-spanien.com\n"
"jamaica-star.com\n"
"paradiselandingwi.com\n"
"lovetoloves.com\n"
"cddwyy.com\n"
"hapt01.cn\n"
"duartelawfirm.com\n"
"moskvin.ca\n"
"idc029.com\n"
"ronincast.com\n"
"sonnydickson.com\n"
"brightsign.com\n"
"schaer-info.de\n"
"congtynhunghuou.com\n"
"inpromocenter.com\n"
"theperfectoutfit.net\n"
"cenblog.org\n"
"emesce.com\n"
"mrirad.com\n"
"acswebdevelopment.com\n"
"aze.bz\n"
"elevenparis.com\n"
"stylesitte.com\n"
"kathihill.com\n"
"dmxis.com\n"
"astrology-readings.com\n"
"mujerlunabella.org\n"
"kcoolonline.com\n"
"drifty.com\n"
"ducaticlub.vn\n"
"webwaterland.nl\n"
"vk.me\n"
"starepolesie.pl\n"
"apamanshop-aichi.com\n"
"vk.me\n"
"ibermatica.com\n"
"sexhealthexpert.com\n"
"thevisualecho.com\n"
"afy.ru\n"
"aaronwhitaker.com\n"
"mybaby2017.ru\n"
"igrfan.ru\n"
"sjwmcs.kr\n"
"gigposters.com\n"
"firmanetworks.com\n"
"winefestivalattheplains.com\n"
"highfielddental.co.uk\n"
"babyweb.sk\n"
"socialtechnologydesign.com\n"
"care4horses.net\n"
"mobi03.ru\n"
"dsl.sk\n"
"expd8.com\n"
"phpmagazin.de\n"
"birthdaycardsayings.net\n"
"rpy-italia.org\n"
"portablefirepitx.com\n"
"cookrepublic.com\n"
"fashionista514.com\n"
"bakaon.com\n"
"nekostudio.net\n"
"navtechradar.com\n"
"losefatpronto.com\n"
"sustainabletriangle.com\n"
"bs-holzgigant.de\n"
"todaysgeneralcounsel.com\n"
"acitydumpsters.com\n"
"vk.me\n"
"runyusha.ru\n"
"p2a.pl\n"
"bostondesis.com\n"
"kujian.com\n"
"garnier.ca\n"
"tafreevar.com\n"
"chouf-chouf.com\n"
"nestormedia.com\n"
"irobot.com\n"
"greatmillstone.info\n"
"ch-go.ch\n"
"friendfinderinc.com\n"
"nigerianbulletin.com\n"
"taleera.com\n"
"e-taneya.com\n"
"dpointsrvcs.com\n"
"razorbackironwork.com\n"
"legalis.net\n"
"worldtunez.com\n"
"admbel.ru\n"
"biotechinfo.in\n"
"taroscopes.com\n"
"lcui.org\n"
"eradek.ru\n"
"scgolfpanel.org\n"
"closethebase.org\n"
"servnettech.com\n"
"hourlyfreesex.com\n"
"ybgli.org\n"
"naomix.com\n"
"projecocontracting.com\n"
"camcard.com\n"
"dpatrickporsche.com\n"
"genderoffenders.com\n"
"gardeninginflorida.com\n"
"infografeno.com\n"
"esporta.nl\n"
"digimail.se\n"
"mwcloudplatform.com\n"
"energymedicine.org\n"
"ubllcdhn.com\n"
"yenta4.com\n"
"frankrust.com\n"
"kylemedia.com\n"
"la-phoceenne.com\n"
"uc.cl\n"
"smartstorexperience.com\n"
"amedeos.net\n"
"car-crm.net\n"
"centromiami.com\n"
"exoupdates.com\n"
"moneyam.com\n"
"swoo.co.uk\n"
"oz4abh.dk\n"
"mbohal.cz\n"
"easypage.fi\n"
"smoro.fr\n"
"jennifermay.com\n"
"owlcreek.com\n"
"playmileycyrusgames.com\n"
"syasyou.com\n"
"chimeraenterprisellc.com\n"
"ncesc1.com\n"
"sailor.pl\n"
"spectrumgp.com\n"
"thepinotproject.com\n"
"akrockefeller.com\n"
"supreetsethi.net\n"
"winneralex.ru\n"
"nechakohca.ca\n"
"awacademy.org\n"
"urazova.ru\n"
"mosquitoblocker.com\n"
"powerdnn.co.uk\n"
"realestateownedsolutions.com\n"
"westchesteracupuncture.us\n"
"public-trust.com\n"
"gic.pt\n"
"ciaoseminars.com\n"
"mercyimaging.org\n"
"advis.pl\n"
"themarcellusshale.com\n"
"vladmama.ru\n"
"louisvuittoncareers.com\n"
"lustygrannies.org\n"
"vini-divini.be\n"
"viverelivata.com\n"
"artemedya.net\n"
"huatki.com\n"
"kuzovnoy.ru\n"
"komsil.com\n"
"discovercheapstuff.com\n"
"groundriddim.com\n"
"exquisitestairs.com\n"
"a-mail.nl\n"
"willsoft.fi\n"
"photo-videoforum.com\n"
"momonduty.com\n"
"epo.nl\n"
"waimailuntan.com\n"
"e-xpress.net\n"
"naturestonehomes.com\n"
"refog.net\n"
"weblancer.net\n"
"kodanshacomics.com\n"
"hydrant.co.uk\n"
"el.nl\n"
"logderma.ru\n"
"digitalhart.com\n"
"imitationbamboo.net\n"
"soulbrasil.com\n"
"crescentstables.com\n"
"dogcatkorm.ru\n"
"betavak.nl\n"
"paddock-review.com\n"
"philnews.com\n"
"styleblazer.com\n"
"pbase.com\n"
"smxsports.se\n"
"susieanderson.com\n"
"docthan.com\n"
"thelittlegive.ca\n"
"cxtg.net\n"
"supportthevets.org\n"
"cartagraf.com\n"
"nicaa.org\n"
"caworks-sl.de\n"
"midgard-pictures.ch\n"
"powernotebooks.com\n"
"vk.me\n"
"gamblespot.ru\n"
"retrovisionmedia.com\n"
"hermansingers.nl\n"
"247floodresponse.com\n"
"edisonenergia.it\n"
"housingscotlandtoday.com\n"
"helenecastelli.com\n"
"noveroma.com\n"
"urivalet.com\n"
"paheal.net\n"
"otohakan.com\n"
"guardiancremation.com\n"
"insidebusinesstravel.com\n"
"qq.com\n"
"art-kon-tor.de\n"
"mserve.com\n"
"yourpowerdrills.com\n"
"thehostfan.com\n"
"mkbkantoorartikelen.nl\n"
"misssocialbabe.com\n"
"drtaffi.com\n"
"kenils.co.in\n"
"jbei.org\n"
"pearl-institute.co.jp\n"
"evertidegames.com\n"
"lemmecheck.info\n"
"scriptolution.com\n"
"uon.it\n"
"truball.com\n"
"monumen.pl\n"
"worldweapon.info\n"
"uigc.net\n"
"fonua.com\n"
"thecancerzone.net\n"
"tamquoctutien.com\n"
"bentowich.com\n"
"sariikankutuk.com\n"
"music-courses.com\n"
"downwithbloatware.com\n"
"xqgcab.com\n"
"buypasta.net\n"
"zugullotto.com\n"
"iag-inc.com\n"
"orenboxing.org\n"
"healingprovision.com\n"
"vestonhaiphong.com\n"
"accordiagolf.com\n"
"verlockeshop.de\n"
"d2job.com\n"
"corinneduyvis.com\n"
"publidesign.be\n"
"ponroy.com\n"
"lsycz.net\n"
"lgmonitorreview.nl\n"
"conegliano.tv.it\n"
"wigh.net\n"
"webberdigits.com\n"
"jillainecarlin.com\n"
"szpabj.com\n"
"service-sncf.com\n"
"greystonemoore.co.uk\n"
"138mr.com\n"
"curiousmarketeer.com\n"
"bassmatters.nl\n"
"datamatix.co.uk\n"
"vk.me\n"
"qalebfa.ir\n"
"gymboree.com\n"
"carolgraykennedy.com\n"
"forfun.us\n"
"gateable.com\n"
"konya.co.jp\n"
"citistreetonline.com\n"
"funeralscriptphp.com\n"
"goesuperled.com\n"
"meredithnovario.com\n"
"1200.kg\n"
"aacs.net\n"
"pawsgalorepetsitters.com\n"
"italiansuitsformen.net\n"
"profil.hr\n"
"ekoulotki.pl\n"
"peek-cloppenburg.be\n"
"door2games.com\n"
"vk.me\n"
"ks-auxilia.de\n"
"jewishfoodtogo.com\n"
"funecole.com\n"
"vk.me\n"
"stersong44.in\n"
"stratasys.com\n"
"pwt5.com\n"
"jyskweb.dk\n"
"priozerskfm.ru\n"
"delhitourism.com\n"
"spareparttoyotaonline.com\n"
"flashbay.de\n"
"ruspo.ru\n"
"squarespace.com\n"
"huynhduc.net\n"
"iberianhorsemarket.com\n"
"engagedcrm.co.uk\n"
"kitepackaging.co.uk\n"
"my-mps.com\n"
"extremevision.com\n"
"allfon.com\n"
"citymapper.com\n"
"eqdc.nl\n"
"fjordnorway.com\n"
"dbg.co.za\n"
"paris-photo.ru\n"
"xspgulf.net\n"
"foreveramber.co.uk\n"
"acadianseaplanes.com\n"
"pohistvo-mobile.si\n"
"piedivelati.com\n"
"pagely.com\n"
"egyptiansociety.net\n"
"parulassociates.com\n"
"tmatesoft.com\n"
"themackfamily.co.uk\n"
"koszulka.tv\n"
"mp3an.biz\n"
"ghanja.be\n"
"lisabyington.com\n"
"marciglass.com\n"
"mssm.edu\n"
"teenbabesinsocks.com\n"
"forexcafe.com\n"
"galucho.pt\n"
"zak-clan.com\n"
"bsc-building-suppliers.com\n"
"bomcheck.net\n"
"warvar.ru\n"
"actionfenceco.com\n"
"airagestore.com\n"
"godoroso-zenkokukyou.org\n"
"telefonszamkereses.hu\n"
"compassionatepractice.com\n"
"davids-garden-seeds-and-products.com\n"
"iom.no\n"
"marketsnavigator.com\n"
"franceguide.com\n"
"mosesys.com\n"
"kitag.com\n"
"flekspak.com\n"
"justdownforme.com\n"
"traditioninaction.org\n"
"russkie-palaty.ru\n"
"zappcart.com\n"
"federazionepagana.it\n"
"oxbowestate.co.za\n"
"stansteadstonecircle.org\n"
"surechef.com\n"
"michiphotostory.com\n"
"secuteach.de\n"
"keaiq.com\n"
"zbsd.cn\n"
"momtubetv.com\n"
"estetdoctor.com\n"
"giantpeachtest.com\n"
"staithe.net\n"
"intelnett.com\n"
"stardem.com\n"
"fitmole.org\n"
"v2v.cc\n"
"cyberbude.de\n"
"citapreviainem.es\n"
"jp.org\n"
"junpinzhi.cn\n"
"chillindia.com\n"
"byroommate.com\n"
"aquil.ca\n"
"boschlawnmowers.com\n"
"114school.cn\n"
"dampack.nl\n"
"petrovichmedia.ru\n"
"eco-mylife.com\n"
"formular.ru\n"
"betbetcom.com\n"
"very-pc.co.uk\n"
"dominosugar.com\n"
"fk.ro\n"
"santinopizza.co.uk\n"
"ardasenov.ru\n"
"linuxtutorial.info\n"
"permaculture.coop\n"
"burpboutique.com\n"
"ep-coatings.co.uk\n"
"hcbd.biz\n"
"rondjesauna.info\n"
"happinessthisway.com\n"
"delta3d.org\n"
"search-homes.org\n"
"nissanrancagua.com\n"
"compartstudio.com\n"
"cn.com\n"
"romboutskorea.co.kr\n"
"careerbuilder.eu\n"
"artinzert.cz\n"
"zag.si\n"
"merck.de\n"
"whatkatewore.com\n"
"ntyfranchise.com\n"
"madisoncountyky.us\n"
"florian-pennec.net\n"
"motleycoder.com\n"
"sitecore.net\n"
"formless.info\n"
"best4u.ir\n"
"farraway.co.za\n"
"cnczone.nl\n"
"bargainjoy.com\n"
"globalmarketinggroup.org\n"
"logicalshop.com\n"
"your-home-design.com\n"
"spellekijn.nl\n"
"sydneycomputershops.com\n"
"childrenandtoddlers.com\n"
"cool-backgrounds.org\n"
"wsulaw.com\n"
"themrsbox.com\n"
"cancelpage.com\n"
"happyturtle.ca\n"
"softactivity.com\n"
"gxjbsj.com\n"
"srpa.org\n"
"wkf.fr\n"
"sbimo.com\n"
"nordjyskelejligheder.dk\n"
"onlineuniversity.net\n"
"atotech.com\n"
"gamepreschooler.com\n"
"abix.fr\n"
"rhsport.pl\n"
"cogizz.com\n"
"zeninformatica.com\n"
"cipafilter.com\n"
"g32.nl\n"
"za.net\n"
"karmanebula.com\n"
"bonusnopurchaserequired.com\n"
"keycast.com\n"
"go2bot.com\n"
"webair.com\n"
"snapfish.fr\n"
"smsagencies.co.uk\n"
"appendad.com\n"
"pcomoney.com\n"
"churchgrowth.org\n"
"anadoluyakasikuryesi.com\n"
"calmcdn.com\n"
"agrogepaciok.it\n"
"todoofeminin.com\n"
"lettredesreseaux.com\n"
"bestteensex.net\n"
"mocean.com\n"
"youload.com\n"
"quickdollaracademy.com\n"
"pandorajewelleryoutlets.com\n"
"160tracker.com\n"
"deurdrangers-shop.nl\n"
"tcdn.ru\n"
"severnaparkaspire.com\n"
"meleahhall.com\n"
"powermax-motorsport.com\n"
"longfeel.com\n"
"american.com\n"
"ogretmenim.biz\n"
"ifeng.fm\n"
"highereducationarticles.com\n"
"seyiyi.com\n"
"person-centred-counselling.com\n"
"fatstrawberry.com\n"
"protechblog.com\n"
"modenaradiocity.it\n"
"z51.biz\n"
"yakutia.info\n"
"vk.me\n"
"baskid.co.uk\n"
"okfree.net\n"
"genderqueerid.com\n"
"hercuton.nl\n"
"thespafitnesscenter.com\n"
"juliabloggers.com\n"
"awlawyers.com\n"
"stmargaretbbay.com\n"
"candlelightcottages.com\n"
"abctvlive.com\n"
"muabancaooc.net\n"
"dtlsitead.com\n"
"aster.it\n"
"georgesmion.com\n"
"lowcostpower.com\n"
"prisonnotebooks.com\n"
"johnsaey.be\n"
"vzkj.net\n"
"pompalisap.com\n"
"kartalkule.com\n"
"countingpips.com\n"
"fleurmusic.com\n"
"vipbrands.com\n"
"eaglefam.us\n"
"adoos.com\n"
"toughcountry.net\n"
"cinnabar.cc\n"
"naturalna-medicina.sk\n"
"linksplash.info\n"
"ttspro.com\n"
"rousing.dk\n"
"qkmedica.com\n"
"freeconferencecallhd.com\n"
"abahe.co.uk\n"
"monitis.com\n"
"chuyenchame.com\n"
"fishingarticle.com\n"
"arpnamehtaphotography.com\n"
"conocophillips.com\n"
"dakotaeye.com\n"
"intelligentadoption.com\n"
"51wasai.com\n"
"camdencentreport.com\n"
"isoc.si\n"
"lordswitness.com\n"
"sandiegocubicles.com\n"
"lifecharlotte.com\n"
"bethappleton.com\n"
"39bencao.com\n"
"pandapow.us\n"
"dilw.ie\n"
"spst.edu\n"
"meshmixer.com\n"
"exceedingexpectationsllc.com\n"
"hdcore.eu\n"
"4teens-serial.cz\n"
"khaokhotalamok.com\n"
"leylandsdm.co.uk\n"
"nicenews.co.kr\n"
"donberg.co.uk\n"
"queenslandimages.com\n"
"ecole-movie.jp\n"
"topcities.com\n"
"howardlindzon.com\n"
"millionfareast.com\n"
"shhzhiyektv.com\n"
"professionalmuscle.com\n"
"talkrocktome.com\n"
"prestigioplaza.com\n"
"platum.kr\n"
"portalpublicitario.com\n"
"hdcric.com\n"
"whatismyip.com\n"
"imb-jena.de\n"
"scientificdrilling.com\n"
"topwallpaperpictures.com\n"
"ikea.gr\n"
"biocell.ie\n"
"lesmargouillats.com\n"
"periodicoguama.org\n"
"musicindiaonline.com\n"
"indicitalia.com\n"
"hotelmangalampalace.com\n"
"one3ofidahorealestate.com\n"
"ourpictures.com\n"
"dynsite.net\n"
"sonami.co.jp\n"
"laconic-records.de\n"
"vacationsdirect.com\n"
"eu.pn\n"
"sangmaestro.com\n"
"rocketmatter.com\n"
"114chn.com\n"
"zencleanse.net\n"
"mettsrv.ru\n"
"birdiebikes.co.uk\n"
"haninportal.com\n"
"solofemaletraveler.com\n"
"delinquencyrates.com\n"
"season.kz\n"
"japanesewords.net\n"
"apssci.org\n"
"batisteandassociates.com\n"
"dnstechpack.com\n"
"adslook.net\n"
"neotext.ru\n"
"cleverpost.ru\n"
"ironsocket.com\n"
"captordetectives.com\n"
"leczeniezatok.com\n"
"tamfly.net\n"
"drivesrvr.com\n"
"featherhairextensions.co\n"
"arabmoviez.info")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")