// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:([[:alnum:]_-]{1,63})\.)*(?:[[:alnum:]-]{2,63})(?:\.[[:alpha:]]{2,63})+$").unwrap();
let string = "1
11.com
1.2.3.4
1.1.2
1ab.com
www.domain.com
domain.com
53dw4vbsf3yf53nnc7yq7fijlp7ymnbx.dkim.amazonses.com
53dw4vbsf3yf53nnc7yq7fijlp7ymnbx._domainkey.domain.com
a.b.c.d.e.f.ggg.com.au
a1b2c3.com
a111.com
http://nope.com
example
webmagnat.ro
nickelfreesolutions.com
scheepvaarttelefoongids.nl
tursan.net
plannersanonymous.com
doing.fr
saltstack.com
deconsquad.com
migom.com
tjprc.org
worklife.dk
inno-make.com
food-hub.org
bikemastertool.com
betenbewegen.de
vk.me
twotigersports.com
517mrt.com
siel.nl
e-hps.com
infowheel.com
synirc.net
abuliyan.com
easy-ways.com
stark.dk
funwirks.com
eurocqs.net
202yx.com
nikko-sake.com
xnet.lv
visionpharma.com
trade-india.com
t-bird.edu
siebel-crm.net
adriaticapress.it
41789.com
autofirenze.biz
minniowa.com
sweetteaproper.com
recruit-dc.co.jp
competitivecameras.com
zoncinta.com
vadim-prostakov.ru
vk.me
securitasweb.it
mandarinclass.my
pbxi.net
zyznowski.pl
meodia.com
niceinternetmoney.ru
guardiancaps.com
bbccable.net
ams-luenen.de
ihalehaberbulteni.com
salvia-community.net
superpowerfruits.com
bereyellingergl.com
downloadfreetvseries.com
iqshop.ro
urbancliq.com
rocket-media.net
uskudarhaliyikama.org
ftbp.ro
savedeo.com
nanabit.net
memewood.com
divorcereform.us
solarincomefund.com
novofri.com
8852088.com
admil.ru
rafonline.org
bois-francs.com
pieceinch.com
tel.com
teenpregnancysc.org
wisdomforhealth.net
powgnar.com
screenmediamag.com
pricerabbit.com
archive-host.fr
hotimpit.ru
detskie-krovatki.by
3sitracking.com
hellfiremods.co.uk
eslyoga.com
buyphen375cheap.com
kilgour.com
vk.me
hualienhouse.com
tour-box.ru
servizioallerta.it
denyojp.com
2912muranoway.info
centralepiecesauto.com
bluedynamics.com
xjs123.com
veryicon.com
emrekoldas.com
adc-inspect.com
vusadbe.by
morban.co.uk
hainanair.us
vk.me
metar.gr
reviewsearchfree.com
treasureislandbar.com
mobilier-bebe.com
bvillaseminyak.com
sponsoredhomepage.com
santifortwo.com
pcrecruiter.net
bcdtofu.com
thefavorite.fr
aneventapart.com
pces.in
alamelphan.com
hotel63.com
kitubi.com
zenrog.com
kinderroller.org
naverisk.com
teme.us
tlinkbroadband.com
de.vc
rivnetwork.com
bufobufo.eu
friatider.se
mannllc.com
rideukbmx.com
agnx.com
stackablehost.com
muzed.co.uk
up247.me
vk.com
urt.is
notabilus.com
jordansun.com
frosta.hu
lacuisinedegandi.net
baolongphoto.com
sheispriceless.com
retail.ua
pattaya-bargirl-investigations.com
teksyndicate.com
d-strage.jp
akselparis.com
lilylolo.co.uk
mockquestions.com
rocketdownload.com
shopkeepapp.com
postageapp.com
mkhoj.com
ingwer-gesundheit.de
velvetblues.com
deltacountytx.com
idenyt.dk
searchforrecipes.info
simf-net.ru
fraserwebdesign.co.uk
runboard.com
worldoutofbalance.org
amrefgermany.de
ricochettrendz.com
logicspot.net
johnbarritt.com
westfest.co.nz
x-muehle.de
vk.me
ford-2sale.com
kinoman.tv
akorda.kz
terrania.ru
selmanpeskir.com
waydesgin.com
jcdrepair.com
omegamepis.com
answersforapple.com
videofeet.com
luxeweddingdesign.com
thepropertyvault.co.uk
managedemail.com
hrhairextensions.com
triecienspeks.lv
photoshooting-art.com
dns-roots.net
statice.is
sygeforsikring.dk
pleg.ma
memecorner.com
wimmercycle.com
sugoikr.com
hennensobserver.com
phim8.vn
kaoxve.com
mastitorrents.com
choople.com
all-nude-celebs.us
techpowertw.com
gwynnemeeks.com
eissmann.com
foxydeal.in
bigglook.com
camdough.com
blazingcore.com
vn-logistics.nl
hacogata.com
inspiradigital.co.uk
ce-richtlinien.eu
djbarryblends.com
untitledradio.com
chinahomegift.com
zgdaliw.com
qfpay.com
84tao.com
farat.ru
sootooo.com
vk.me
trianglemoon.com
golf-absolute.de
grtplains.com
windmillchiropractic.com
thegrillbbqstore.com
veronline.li
giga-cv.com
xaman.com
maurerundpartner.com
opf-labs.org
plinks.jp
lithiaelectrolysis.com
kentuckysportsradio.com
welding.su
design-pilot.com
wcsr.com
telemagazyn.pl
coldclimategardening.com
dallenhomeschoolreviews.com
guidgen.com
cafe-campus.ru
helander.co.uk
odwyk.com
toppsfootball.co.uk
morgane-le-fay.de
khamphamientrung.com
tas-t.com
comeser.it
spvgg-haddamshausen.de
winkhaus.com
netbridge.ro
frenzyestate.com
comprabolsos.com
medicclub.ru
akfarsam.ac.id
vk.me
rw-kupplungen.de
archers-contois.fr
dyndns.tv
visits.lt
us.tf
wholesalejerseyssaleus.com
supertabak.ru
vk.me
maketechpr.com
registratuperro.com
z9project.com
menkousou.com
futchfactor.com
sauipe.vc
peregrineadventures.com
daegusoft.com
rvillageman.com
ocs1.org
valleyfireworks.net
vk.me
jw.org
mcafeefamilyprotection.com
leblogexpectra.fr
schreibwirkstatt.de
doommovie.com
1600x1200.net
xn--verstt-eua3l.info
wallofsoundstudios.com
leernetwerkeducatie.nl
frommyheartproductions.net
pokupaisumom.ee
stiahnut.sk
fusionedgephotography.com
forum-wf.de
webmusic.asia
cic-tripleadvantage-creditreports.net
deeperfaith.org
geneeskundeboek.nl
andrewraposo.com
poolrepairaustin.com
ayto-oviedo.es
arianapassion.com
mpa-ppm.org
regus.it
myboardcast.com
amanto.be
srsportal.com
staffingcalendar.com
haikoheinz.de
bestelectriclawnmower.co.uk
ruitx.cn
jbbr.net
afresnohomeinspector.com
bathroomgurureview.mobi
barcanovainfantilijuvenil.cat
matandme.com
myra.com
search225.com
egyptopia.com
englishwordsexplained.com
spinetrac.com
tchl.us
az.gov
gaybodyblog.com
mailkenti.net
alldisneycartoons.com
globaldir.org
van-photo.com
alcostop.org
kurkiewicz-family.com
bookmarkingpages.com
newyork.com
karrdoctor.biz
herrajesarena.com
afisha64.ru
patsem2013.org
bikersworld-rathenow.de
openstreetmap.fr
jriver.com
umka.com
shipbroker.no
tradefair.com
tenkarausa.com
wincrm.net
usenettools.net
crsgfk.de
ellowcn.com
imperialantiques.com
moph.go.th
sharedpregnancy.org
youtubeinmp3.com
haoyisheng.com
silkroadtours.com
glsbc.com
downsyndromeiscool.com
tomsgames.it
mysearch-online.com
studiototal.se
glas-forschung.info
intuitionstraining.org
stedelijkgymnasiumhaarlem.nl
thecroydoncitizen.com
oddstowinworldseries.com
vivesoy.com
gt.com
ehgou.com
labelproducts.com
moln.is
mcdonaldsleon.com
ashishlunawat.com
vnsofts.com
idospower.cz
mmblog.tw
glob-marks.com
sceper.ws
thurlownunn.co.uk
moriyama.com
thompsonnutritionals.com
wandern-trekking-spanien.com
jamaica-star.com
paradiselandingwi.com
lovetoloves.com
cddwyy.com
hapt01.cn
duartelawfirm.com
moskvin.ca
idc029.com
ronincast.com
sonnydickson.com
brightsign.com
schaer-info.de
congtynhunghuou.com
inpromocenter.com
theperfectoutfit.net
cenblog.org
emesce.com
mrirad.com
acswebdevelopment.com
aze.bz
elevenparis.com
stylesitte.com
kathihill.com
dmxis.com
astrology-readings.com
mujerlunabella.org
kcoolonline.com
drifty.com
ducaticlub.vn
webwaterland.nl
vk.me
starepolesie.pl
apamanshop-aichi.com
vk.me
ibermatica.com
sexhealthexpert.com
thevisualecho.com
afy.ru
aaronwhitaker.com
mybaby2017.ru
igrfan.ru
sjwmcs.kr
gigposters.com
firmanetworks.com
winefestivalattheplains.com
highfielddental.co.uk
babyweb.sk
socialtechnologydesign.com
care4horses.net
mobi03.ru
dsl.sk
expd8.com
phpmagazin.de
birthdaycardsayings.net
rpy-italia.org
portablefirepitx.com
cookrepublic.com
fashionista514.com
bakaon.com
nekostudio.net
navtechradar.com
losefatpronto.com
sustainabletriangle.com
bs-holzgigant.de
todaysgeneralcounsel.com
acitydumpsters.com
vk.me
runyusha.ru
p2a.pl
bostondesis.com
kujian.com
garnier.ca
tafreevar.com
chouf-chouf.com
nestormedia.com
irobot.com
greatmillstone.info
ch-go.ch
friendfinderinc.com
nigerianbulletin.com
taleera.com
e-taneya.com
dpointsrvcs.com
razorbackironwork.com
legalis.net
worldtunez.com
admbel.ru
biotechinfo.in
taroscopes.com
lcui.org
eradek.ru
scgolfpanel.org
closethebase.org
servnettech.com
hourlyfreesex.com
ybgli.org
naomix.com
projecocontracting.com
camcard.com
dpatrickporsche.com
genderoffenders.com
gardeninginflorida.com
infografeno.com
esporta.nl
digimail.se
mwcloudplatform.com
energymedicine.org
ubllcdhn.com
yenta4.com
frankrust.com
kylemedia.com
la-phoceenne.com
uc.cl
smartstorexperience.com
amedeos.net
car-crm.net
centromiami.com
exoupdates.com
moneyam.com
swoo.co.uk
oz4abh.dk
mbohal.cz
easypage.fi
smoro.fr
jennifermay.com
owlcreek.com
playmileycyrusgames.com
syasyou.com
chimeraenterprisellc.com
ncesc1.com
sailor.pl
spectrumgp.com
thepinotproject.com
akrockefeller.com
supreetsethi.net
winneralex.ru
nechakohca.ca
awacademy.org
urazova.ru
mosquitoblocker.com
powerdnn.co.uk
realestateownedsolutions.com
westchesteracupuncture.us
public-trust.com
gic.pt
ciaoseminars.com
mercyimaging.org
advis.pl
themarcellusshale.com
vladmama.ru
louisvuittoncareers.com
lustygrannies.org
vini-divini.be
viverelivata.com
artemedya.net
huatki.com
kuzovnoy.ru
komsil.com
discovercheapstuff.com
groundriddim.com
exquisitestairs.com
a-mail.nl
willsoft.fi
photo-videoforum.com
momonduty.com
epo.nl
waimailuntan.com
e-xpress.net
naturestonehomes.com
refog.net
weblancer.net
kodanshacomics.com
hydrant.co.uk
el.nl
logderma.ru
digitalhart.com
imitationbamboo.net
soulbrasil.com
crescentstables.com
dogcatkorm.ru
betavak.nl
paddock-review.com
philnews.com
styleblazer.com
pbase.com
smxsports.se
susieanderson.com
docthan.com
thelittlegive.ca
cxtg.net
supportthevets.org
cartagraf.com
nicaa.org
caworks-sl.de
midgard-pictures.ch
powernotebooks.com
vk.me
gamblespot.ru
retrovisionmedia.com
hermansingers.nl
247floodresponse.com
edisonenergia.it
housingscotlandtoday.com
helenecastelli.com
noveroma.com
urivalet.com
paheal.net
otohakan.com
guardiancremation.com
insidebusinesstravel.com
qq.com
art-kon-tor.de
mserve.com
yourpowerdrills.com
thehostfan.com
mkbkantoorartikelen.nl
misssocialbabe.com
drtaffi.com
kenils.co.in
jbei.org
pearl-institute.co.jp
evertidegames.com
lemmecheck.info
scriptolution.com
uon.it
truball.com
monumen.pl
worldweapon.info
uigc.net
fonua.com
thecancerzone.net
tamquoctutien.com
bentowich.com
sariikankutuk.com
music-courses.com
downwithbloatware.com
xqgcab.com
buypasta.net
zugullotto.com
iag-inc.com
orenboxing.org
healingprovision.com
vestonhaiphong.com
accordiagolf.com
verlockeshop.de
d2job.com
corinneduyvis.com
publidesign.be
ponroy.com
lsycz.net
lgmonitorreview.nl
conegliano.tv.it
wigh.net
webberdigits.com
jillainecarlin.com
szpabj.com
service-sncf.com
greystonemoore.co.uk
138mr.com
curiousmarketeer.com
bassmatters.nl
datamatix.co.uk
vk.me
qalebfa.ir
gymboree.com
carolgraykennedy.com
forfun.us
gateable.com
konya.co.jp
citistreetonline.com
funeralscriptphp.com
goesuperled.com
meredithnovario.com
1200.kg
aacs.net
pawsgalorepetsitters.com
italiansuitsformen.net
profil.hr
ekoulotki.pl
peek-cloppenburg.be
door2games.com
vk.me
ks-auxilia.de
jewishfoodtogo.com
funecole.com
vk.me
stersong44.in
stratasys.com
pwt5.com
jyskweb.dk
priozerskfm.ru
delhitourism.com
spareparttoyotaonline.com
flashbay.de
ruspo.ru
squarespace.com
huynhduc.net
iberianhorsemarket.com
engagedcrm.co.uk
kitepackaging.co.uk
my-mps.com
extremevision.com
allfon.com
citymapper.com
eqdc.nl
fjordnorway.com
dbg.co.za
paris-photo.ru
xspgulf.net
foreveramber.co.uk
acadianseaplanes.com
pohistvo-mobile.si
piedivelati.com
pagely.com
egyptiansociety.net
parulassociates.com
tmatesoft.com
themackfamily.co.uk
koszulka.tv
mp3an.biz
ghanja.be
lisabyington.com
marciglass.com
mssm.edu
teenbabesinsocks.com
forexcafe.com
galucho.pt
zak-clan.com
bsc-building-suppliers.com
bomcheck.net
warvar.ru
actionfenceco.com
airagestore.com
godoroso-zenkokukyou.org
telefonszamkereses.hu
compassionatepractice.com
davids-garden-seeds-and-products.com
iom.no
marketsnavigator.com
franceguide.com
mosesys.com
kitag.com
flekspak.com
justdownforme.com
traditioninaction.org
russkie-palaty.ru
zappcart.com
federazionepagana.it
oxbowestate.co.za
stansteadstonecircle.org
surechef.com
michiphotostory.com
secuteach.de
keaiq.com
zbsd.cn
momtubetv.com
estetdoctor.com
giantpeachtest.com
staithe.net
intelnett.com
stardem.com
fitmole.org
v2v.cc
cyberbude.de
citapreviainem.es
jp.org
junpinzhi.cn
chillindia.com
byroommate.com
aquil.ca
boschlawnmowers.com
114school.cn
dampack.nl
petrovichmedia.ru
eco-mylife.com
formular.ru
betbetcom.com
very-pc.co.uk
dominosugar.com
fk.ro
santinopizza.co.uk
ardasenov.ru
linuxtutorial.info
permaculture.coop
burpboutique.com
ep-coatings.co.uk
hcbd.biz
rondjesauna.info
happinessthisway.com
delta3d.org
search-homes.org
nissanrancagua.com
compartstudio.com
cn.com
romboutskorea.co.kr
careerbuilder.eu
artinzert.cz
zag.si
merck.de
whatkatewore.com
ntyfranchise.com
madisoncountyky.us
florian-pennec.net
motleycoder.com
sitecore.net
formless.info
best4u.ir
farraway.co.za
cnczone.nl
bargainjoy.com
globalmarketinggroup.org
logicalshop.com
your-home-design.com
spellekijn.nl
sydneycomputershops.com
childrenandtoddlers.com
cool-backgrounds.org
wsulaw.com
themrsbox.com
cancelpage.com
happyturtle.ca
softactivity.com
gxjbsj.com
srpa.org
wkf.fr
sbimo.com
nordjyskelejligheder.dk
onlineuniversity.net
atotech.com
gamepreschooler.com
abix.fr
rhsport.pl
cogizz.com
zeninformatica.com
cipafilter.com
g32.nl
za.net
karmanebula.com
bonusnopurchaserequired.com
keycast.com
go2bot.com
webair.com
snapfish.fr
smsagencies.co.uk
appendad.com
pcomoney.com
churchgrowth.org
anadoluyakasikuryesi.com
calmcdn.com
agrogepaciok.it
todoofeminin.com
lettredesreseaux.com
bestteensex.net
mocean.com
youload.com
quickdollaracademy.com
pandorajewelleryoutlets.com
160tracker.com
deurdrangers-shop.nl
tcdn.ru
severnaparkaspire.com
meleahhall.com
powermax-motorsport.com
longfeel.com
american.com
ogretmenim.biz
ifeng.fm
highereducationarticles.com
seyiyi.com
person-centred-counselling.com
fatstrawberry.com
protechblog.com
modenaradiocity.it
z51.biz
yakutia.info
vk.me
baskid.co.uk
okfree.net
genderqueerid.com
hercuton.nl
thespafitnesscenter.com
juliabloggers.com
awlawyers.com
stmargaretbbay.com
candlelightcottages.com
abctvlive.com
muabancaooc.net
dtlsitead.com
aster.it
georgesmion.com
lowcostpower.com
prisonnotebooks.com
johnsaey.be
vzkj.net
pompalisap.com
kartalkule.com
countingpips.com
fleurmusic.com
vipbrands.com
eaglefam.us
adoos.com
toughcountry.net
cinnabar.cc
naturalna-medicina.sk
linksplash.info
ttspro.com
rousing.dk
qkmedica.com
freeconferencecallhd.com
abahe.co.uk
monitis.com
chuyenchame.com
fishingarticle.com
arpnamehtaphotography.com
conocophillips.com
dakotaeye.com
intelligentadoption.com
51wasai.com
camdencentreport.com
isoc.si
lordswitness.com
sandiegocubicles.com
lifecharlotte.com
bethappleton.com
39bencao.com
pandapow.us
dilw.ie
spst.edu
meshmixer.com
exceedingexpectationsllc.com
hdcore.eu
4teens-serial.cz
khaokhotalamok.com
leylandsdm.co.uk
nicenews.co.kr
donberg.co.uk
queenslandimages.com
ecole-movie.jp
topcities.com
howardlindzon.com
millionfareast.com
shhzhiyektv.com
professionalmuscle.com
talkrocktome.com
prestigioplaza.com
platum.kr
portalpublicitario.com
hdcric.com
whatismyip.com
imb-jena.de
scientificdrilling.com
topwallpaperpictures.com
ikea.gr
biocell.ie
lesmargouillats.com
periodicoguama.org
musicindiaonline.com
indicitalia.com
hotelmangalampalace.com
one3ofidahorealestate.com
ourpictures.com
dynsite.net
sonami.co.jp
laconic-records.de
vacationsdirect.com
eu.pn
sangmaestro.com
rocketmatter.com
114chn.com
zencleanse.net
mettsrv.ru
birdiebikes.co.uk
haninportal.com
solofemaletraveler.com
delinquencyrates.com
season.kz
japanesewords.net
apssci.org
batisteandassociates.com
dnstechpack.com
adslook.net
neotext.ru
cleverpost.ru
ironsocket.com
captordetectives.com
leczeniezatok.com
tamfly.net
drivesrvr.com
featherhairextensions.co
arabmoviez.info";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}