$re = '/(?!.*(,|\.|@).*\1.*)^[a-zA-Z0-9 @,\.]{3,}$/m';
$str = 'em@il
em@@l
em@il, test.
^ correct
email, test
^ correct
em@il, test,
^- incorrect 2x \',\'
em@ail, test. @bc.
^- incorrect 2x \'@\'
ema
em';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);