import re
regex = re.compile(r"(?!.*(,|\.|@).*\1.*)^[a-zA-Z0-9 @,\.]{3,}$", flags=re.MULTILINE)
test_str = ("em@il\n"
"em@@l\n\n"
"em@il, test.\n"
"^ correct\n\n"
"email, test \n"
"^ correct\n\n"
"em@il, test, \n"
"^- incorrect 2x ','\n\n"
"em@ail, test. @bc. \n"
"^- incorrect 2x '@'\n\n"
"ema\n"
"em")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")