import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(17|18|19|20|21)\\d{8}\\b";
final String string = "String1: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/2000000000//XXXX/NOTPROVIDED//XXXX/NAME/XXXXXXX XXXX//INFO/XXXXXXXX//XXX/XXXXXXXX/\n\n"
+ "String 2: /TYPE/000/X XXXX XX//CODE/XX//BORI/Dossiernummer: 2111111111 Invoice: 2233333333 (betaling week 00)//XXXX/XXXXXXXXXX//XXXX/NAME/XXXXXXX//INFO/XX00XXXX0000000000//ABC/XXXXXX0XXXX/\n\n"
+ "String 3: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/Dossiernummer 1700000000//EREF/NOTPROVIDED//XXXX/NAME/XX XXXXX XX XXX//INFO/XX000000X0000//XXX/XXXXXXXXXX/\n\n"
+ "String 4: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/Dossiernummer 17000000001//EREF/NOTPROVIDED//XXXX/NAME/XX XXXXX XX XXX//INFO/XX000000X0000//XXX/XXXXXXXXXX/\n\n"
+ "String 5: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/Dossiernummer 180000000a//EREF/NOTPROVIDED//XXXX/NAME/XX XXXXX XX XXX//INFO/XX000000X0000//XXX/XXXXXXXXXX/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}