// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(17|18|19|20|21)\d{8}\b").unwrap();
let string = "String1: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/2000000000//XXXX/NOTPROVIDED//XXXX/NAME/XXXXXXX XXXX//INFO/XXXXXXXX//XXX/XXXXXXXX/
String 2: /TYPE/000/X XXXX XX//CODE/XX//BORI/Dossiernummer: 2111111111 Invoice: 2233333333 (betaling week 00)//XXXX/XXXXXXXXXX//XXXX/NAME/XXXXXXX//INFO/XX00XXXX0000000000//ABC/XXXXXX0XXXX/
String 3: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/Dossiernummer 1700000000//EREF/NOTPROVIDED//XXXX/NAME/XX XXXXX XX XXX//INFO/XX000000X0000//XXX/XXXXXXXXXX/
String 4: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/Dossiernummer 17000000001//EREF/NOTPROVIDED//XXXX/NAME/XX XXXXX XX XXX//INFO/XX000000X0000//XXX/XXXXXXXXXX/
String 5: /TYPE/000/R SEPA TR//XXXX/XX//XXXX/Dossiernummer 180000000a//EREF/NOTPROVIDED//XXXX/NAME/XX XXXXX XX XXX//INFO/XX000000X0000//XXX/XXXXXXXXXX/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}