package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)typedef\s+((?:\w+\s*){1,})\(\*\s*(\w\S+)\s*\)\s*\((.*)\);`)
var str = `typedef unsigned long (*genpool_algo_t)(unsigned long *map,unsigned long size,unsigned long start,unsigned int nr,void *data, struct gen_pool *pool, unsigned long start_addr);
typedef void (*xa_update_node_t)(struct xa_node *node);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}