re = /typedef\s+((?:\w+\s*){1,})\(\*\s*(\w\S+)\s*\)\s*\((.*)\);/m
str = 'typedef unsigned long (*genpool_algo_t)(unsigned long *map,unsigned long size,unsigned long start,unsigned int nr,void *data, struct gen_pool *pool, unsigned long start_addr);
typedef void (*xa_update_node_t)(struct xa_node *node);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end