$re = '/(CASE \d+)(?:(?!CASE \d+)[\s\S])*(Drop Flow: (?:TRUE|FALSE))/m';
$str = 'CASE 1:
----------------------------------
Drop Pack: FALSE
Drop Flow: FALSE
----------------------------------
CASE 2:
----------------------------------
Drop Flow: TRUE
Fail Open: FALSE
Fail Close: FALSE
----------------------------------
CASE 3:
----------------------------------
Drop Flow: FALSE ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);