re = /(CASE \d+)(?:(?!CASE \d+)[\s\S])*(Drop Flow: (?:TRUE|FALSE))/m
str = 'CASE 1:
----------------------------------
Drop Pack: FALSE
Drop Flow: FALSE
----------------------------------
CASE 2:
----------------------------------
Drop Flow: TRUE
Fail Open: FALSE
Fail Close: FALSE
----------------------------------
CASE 3:
----------------------------------
Drop Flow: FALSE '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end