#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ADJ (COMMA ADJ )*)*(NOUN (DASH NOUN )*(DASH )?)*NOUN"
Local $sString = "STOP VERB NOUN NOUN DASH NOUN PUNCT" & @CRLF & _
"STOP VERB STOP ADJ ADJ NOUN STOP STOP ADJ NOUN COMMA NOUN PUNCT" & @CRLF & _
"STOP VERB STOP ADJ COMMA ADJ NOUN PUNCT" & @CRLF & _
"STOP STOP ADJ DASH ADJ NOUN PUNCT" & @CRLF & _
"STOP STOP STOP ADJ NOUN NOUN STOP STOP PUNCT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")