import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ADJ (COMMA ADJ )*)*(NOUN (DASH NOUN )*(DASH )?)*NOUN";
final String string = "STOP VERB NOUN NOUN DASH NOUN PUNCT\n"
+ "STOP VERB STOP ADJ ADJ NOUN STOP STOP ADJ NOUN COMMA NOUN PUNCT\n"
+ "STOP VERB STOP ADJ COMMA ADJ NOUN PUNCT\n"
+ "STOP STOP ADJ DASH ADJ NOUN PUNCT\n"
+ "STOP STOP STOP ADJ NOUN NOUN STOP STOP PUNCT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}