const regex = /\b(?:(?:https?|ftp):\/\/)?([^\/\n]+)\/?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:https?|ftp):\\\/\\\/)?([^\\\/\\n]+)\\\/?', 'gm')
const str = `String
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}