re = /\b(?:(?:https?|ftp):\/\/)?([^\/\n]+)\/?/m
str = 'String
google.com
www.google.com
ftp://ftp.google.com
http://www.google.com
http://www.google.com/
https://www.google.com/
https://www.google.com.sg/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end