using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s""']+|""([^""]*)""|'([^']*)'";
string input = @"get ""something"" from my laptop ""here is"" ""any site lala""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}