re = /[^\s"']+|"([^"]*)"|'([^']*)'/
str = 'get "something" from my laptop "here is" "any site lala"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end