using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?-I[^\s-]*)-(.*)";
string input = @"PSC-CAMPO-GRANDE-I08-V00-C09-H09-IPRMKT";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}