$re = '/(.*?-I[^\s-]*)-(.*)/';
$str = 'PSC-CAMPO-GRANDE-I08-V00-C09-H09-IPRMKT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);