using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"oauth_token=(?P<oauth_token>.*?)&portlet_session=(?P<portlet_session>.*?) ";
string input = @"HTTP/1.1 302 Moved Temporarily Date: Wed, 27 May 2015 09:36:27 GMT Location: /oauth/liferay_redirect.php?oauth_token=23893f24b76534572041d29cfdf11565&portlet_session=8643FDCF76E2212A38316432F4ED8CA7 Content-Length: 0 Vary: Accept-Encoding,User-Agent Content-Type: text/plain; charset=UTF-8
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}