use strict;
my $str = 'HTTP/1.1 302 Moved Temporarily Date: Wed, 27 May 2015 09:36:27 GMT Location: /oauth/liferay_redirect.php?oauth_token=23893f24b76534572041d29cfdf11565&portlet_session=8643FDCF76E2212A38316432F4ED8CA7 Content-Length: 0 Vary: Accept-Encoding,User-Agent Content-Type: text/plain; charset=UTF-8
';
my $regex = qr/oauth_token=(?P<oauth_token>.*?)&portlet_session=(?P<portlet_session>.*?) /p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}