using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\b((?:\w+ +){2}\w+) +(hello) +((?:\w+ +){0,2}\w+\b))";
string input = @"I am going to say hello and hello to him
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}